Athlete Central Mobile Application: Known issue 13NOV2025.

Incident Report for WADA Applications

Resolved

The issue affecting some athletes when saving their 60-minute time slot in the Athlete Central mobile app has now been resolved.
All functionalities are back to normal, and you can safely use the mobile app again.
Thank you for your patience.
Posted Nov 28, 2025 - 15:03 UTC

Identified

We’re aware of an issue affecting some athletes when saving their 60‑minute time slot in the Athlete Central mobile app.
Submissions via ADAMS web remain fully functional.
Please use ADAMS web until the mobile issue is resolved.
We’ll share updates as soon as possible.
Posted Nov 13, 2025 - 22:10 UTC
This incident affected: ADAMS Ecosystem (Athlete Central).