Athlete Central is unavailable

Incident Report for WADA Applications

Resolved

The new version of Athlete Central 1.13.0 is now available on mobile app stores.
Posted May 29, 2025 - 17:28 UTC

Identified

The Athlete Central application is currently unavailable, athletes are asked to use the web version of ADAMS to update their whereabouts.
Posted May 29, 2025 - 09:20 UTC
This incident affected: ADAMS Ecosystem (Athlete Central).